Eza's Image Glutton

Redirects to high-res images on gallery sites, skipping past descriptions and comments

< Feedback on Eza's Image Glutton

Question/comment

§
Posted: 2021-07-10
Bug! the script had stopped working on Furaffinity for me as of a few weeks ago. I'm using the latest version of firefox and violentmonkey for handling scripts. Violentmonkey says that any and all FA submission pages are running the image glutton but nothing ever actually redirects 0_0 Let me know if you need any more info and of what kind
EzaliasAuthor
§
Posted: 2021-07-12
I can't reproduce this issue. I just upgraded my Firefox installation to 89.0.2 and installed Violentmonkey 2.13.0, and while I am logged-out, every FurAffinity submission I try redirects. Logged-in on my main browser and plugin, it looks the same and works the same.

The only recent change has been replacing "redirect();" with "setTimeout( redirect, 1 );" - which should just call redirect() in 1 millisecond. (Or some other small number of milliseconds.) There is no logical reason that should cause a problem... but Javascript does not always obey logical reasons.

So you could try switching to the previous version, and see if that makes FurAffinity work.

Or you could edit that one line back to "redirect();", since that is the only code change from the previous version.

Or you could try a different number of milliseconds? Officially setTimeout is supposed to treat any small number as 10ms, or possibly 4ms. But telling Javascript what it's supposed to do is not a reliable debugging method.

Is it just FurAffinity? Does e621.net work? Does FurAffinity still have some optional UI, such that it looks different for you when you're logged out, or in a Private Window?

If some other script adds a link that's tagged with class "download" then that might interfere.
§
Posted: 2021-07-13
Using:
- Violentmonkeyv2.13.0
- Firefox 89.0.2 (64-bit)

E621, Deviantart, and other sites work just fine, it's only Furaffinity that's having issues. I've disabled all my other add-ons that affect FA and the problem persists, and image glutton is the only userscript running on furaffinity pages.


I just tried changing the redirect line ( #300 ) as you suggested to be just redirect, and then other numbers of milliseconds. It seems that's not the issue as it made no difference. Neither did opening a private window or logging out. I'm going to try restarting firefox next after making this post, and edit it if it ends up working. If there's anything else I can screenshot or otherwise capture for you just let me know.
EzaliasAuthor
§
Posted: 2021-07-14

On a submission page, please press F12 to open the Javascript console. Presumably entering document.querySelector( '.download a[href]' ) returns null?

If so - does document.querySelector( '#submissionImg' ).dataset.fullviewSrc return an image URL? It's fine if it starts with "//".

I could just add that as a fallback and cross my fingers, but I'm worried Firefox has some wider issue with querySelector.

§
Posted: 2021-07-16
Ok gonna do as you asked.

document.querySelector( '.download a[href]' )
null

So yeah that returned a null

document.querySelector( '#submissionImg' ).dataset.fullviewSrc
"//d.furaffinity.net/art/sixthleafclover/1624128059/1624128059.sixthleafclover_bonsai_dragon_comic_1_-_with_water_pale_wm2.jpg"

and the SECOND one returned an image url just fine.
§
Posted: 2021-07-16
Also here might be a helpful thing, I'm watching the concole as I reload the page with a fresh install of the glutton and it's claiming there's a missing Parenthesis somewhere:
§
Posted: 2021-07-16
Also I've discovered Inkbunny also no longer works, which is making the problem even weirder cause it IS still working on deviantart and other sites.
EzaliasAuthor
§
Posted: 2021-07-18
I've added that fallback for FurAffinity.

Inkbunny apparently blocks userscripts via Content Security Policy, which is not something a script can control. Under Violentmonkey's advanced settings, changing "default injection mode" to "page" fixed it on my machine. I don't know how this would affect other scripts.

... or maybe it's haunted, because it stopped working on my machine, minutes later. Sometimes computers just do things.

If this behavior with Violentmonkey and Inkbunny is new, it might be caused by some recent update in Violentmonkey. The extension defaults to "auto" mode, which really ought to catch the CSP error, and then try the other way.
§
Posted: 2021-07-19
*tries tampermonkeyt instead* OOP! YYYYYEP. The problems seem to ALL have been due to Violentmonkey, cause Tampermonkey redirected the FA page to the image first try after installing XD Well THATS fun. *checks* INKBUNNY WORKS TOO. Why the HELL was I ever using Violentmonkey??? Anyways XD Sooooo that's that :P thanks for taking the time to reply and troubleshoot :P and now we know of a potential issue with violentmonkey compatibility, and can reccomend to folks who have problems with the script to run it on NOT vm :P
EzaliasAuthor
§
Posted: 2021-07-21
Violentmonkey's always seemed odd. And yet - I'm never going to open with "Have you tried using a different everything?" because I still use a stupid combination of browser and plugin. This script shows an image you're already looking at. There shouldn't be a browser where that doesn't work.

Post reply

Sign in to post a reply.